Вышел WordPress 5.2 «Jaco» — что нового?

1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (2 оценок, среднее: 5,00 из 5)
Загрузка...

Обеспечение безопасности сайтов

Версия 5.2 WordPress, названная «Jaco» в честь известного и революционного джазового басиста Яко Пасториуса, доступна для загрузки или обновления из панели управления WordPress. Новые функции в этом обновлении упрощают исправление вашего сайта при возникновении неполадок.

Появились более надежные инструменты для выявления и устранения проблем конфигурации и фатальных ошибок. Независимо от того, являетесь ли вы разработчиком или управляете своим сайтом в одиночку, эти инструменты могут помочь вам получить нужную информацию, когда вам это нужно.

Проверка работоспособности сайта Site Health Check

Основываясь на возможностях Site Health,представленных в 5.1, в этом выпуске добавлены две новые страницы, помогающие отладить типичные проблемы конфигурации. Добавлено пространство, где разработчики могут включать отладочную информацию.

Защита от ошибок PHP

Это обновление, ориентированное на администраторов, позволит вам безопасно исправлять или управлять фатальными ошибками. Он обеспечивает лучшую обработку так называемого «белого экрана смерти» и способ входа в режим восстановления, который приостанавливает вызывающие ошибки плагины или темы.

Улучшения для всех

Обновления доступности

Внесен ряд изменений для улучшения понимания контекста и навигации по клавиатуре для тех, кто использует программы чтения с экрана и другие вспомогательные технологии.

Новые значки панели инструментов

Тринадцать новых иконок, включая Instagram, набор иконок для BuddyPress и повернутые иконки Earth.

Проверки совместимости плагинов

WordPress теперь автоматически определяет, совместима ли версия PHP вашего сайта с установленными плагинами. Если для плагина требуется более высокая версия PHP, чем использует ваш сайт, WordPress не позволит вам активировать его, что предотвратит возможные ошибки совместимости.

Для разработчиков

Повышение минимальной версии PHP

Минимальная поддерживаемая версия PHP теперь 5.6.20. Начиная с WordPress 5.2 * темы и плагины могут безопасно использовать пространства имен, анонимные функции и многое другое!

Обновления конфиденциальности

Новый шаблон страницы темы, условная функция и два класса CSS упрощают проектирование и настройку страницы Политики конфиденциальности.

Новый хук Body

5.2 представляет хук wp_body_open, который позволяет темам поддерживать внедрение кода прямо в начале элемента <body>.

Сборка JavaScript

С добавлением конфигураций webpack и Babel в пакет wordpress / scripts разработчикам не придется беспокоиться о настройке сложных инструментов сборки для написания современного JavaScript.

* Если вы используете старую версию PHP (менее 5.6.20), обновите ваш PHP перед установкой 5.2.

1 Comment

  1. Валера29.08.2019

    Главное перед обновлениями этими сделать резерв всего-всего, а то накрутят как обычно каких-то «Гутенбергов»…

    Ответить

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *

Scroll to top